반응형
1. 평균 합격 구하기
- 두 점수를 입력 받고, 평균이 70점 이상이면 합격 그렇지 않으면 불합격을 출력하세요.
입력 예시
두 점수를 입력하세요 : 87 95
출력 예시
합격
풀이
더보기
import java.util.Scanner;
public class Quiz04 {
public static void main(String[] args) {
Scanner scan = new Scanner(System.in);
System.out.print("두 점수를 입력하세요 : ");
int score1 = scan.nextInt();
int score2 = scan.nextInt();
double average = (score1 + score2) / (double)2;
if (average >=70) {
System.out.println("합격");
} else {
System.out.println("불합격");
}
scan.close();
}
}
2. 큰 값 구하기
- 세 개의 정수를 입력 받아서 가장 큰 값을 출력하세요.
입력 예시
세 개의 수를 입력하세요 : 3 8 5
출력 예시
8
풀이
더보기
import java.util.Scanner;
public class Quiz04 {
public static void main(String[] args) {
Scanner scan = new Scanner(System.in);
System.out.print("세 개의 수를 입력하세요 : ");
int a = scan.nextInt();
int b = scan.nextInt();
int c = scan.nextInt();
if (a > b && a > c) {
System.out.println(a);
} else if (b > a && b > c) {
System.out.println(b);
} else {
System.out.println(c);
}
scan.close();
}
}
더 간단한 풀이
import java.util.Scanner;
public class Quiz04 {
public static void main(String[] args) {
Scanner scan = new Scanner(System.in);
int max = a;
if (b > max) {
max = b;
}
if (c > max) {
max = c;
}
scan.close();
}
}
3. 과락 포함 합격 여부
- 점수 두 개를 입력 받고 합격 여부를 출력하세요.
평균이 60점 이상이면 합격
한과목이라도 50점 이하면 무조건 과락
평균 60점 미만이면 불합격
입력 예시
점수1 : 95 점수2 : 48
출력 예시
과락
풀이
더보기
import java.util.Scanner;
public class Quiz04 {
public static void main(String[] args) {
Scanner scan = new Scanner(System.in);
System.out.print("점수1 : ");
int score1 = scan.nextInt();
System.out.print("점수2 : ");
int score2 = scan.nextInt();
double average = (score1 + score2) / (double)2;
if (score1 <= 50 || score2 <=50) {
System.out.println("과락");
} else if (average >= 60) {
System.out.println("합격");
} else {
System.out.println("불합격");
}
scan.close();
}
}
4. 윤년 구하기
- 연도를 입력 받아서 윤년인지 평년인지 출력하세요.
- 윤년 조건
- 4로 나누어 떨어지는 연도는 윤년이다.
- 100으로 나누어 떨어지는 연도는 윤년이 아니다.
- 400으로 나누어 떨어지는 연도는 무조건 윤년이다.
입력 예시
연도 : 2020
출력 예시
윤년
풀이
더보기
import java.util.Scanner;
public class Quiz04 {
public static void main(String[] args) {
Scanner scan = new Scanner(System.in);
if (year % 400 == 0 || year % 4 == 0) {
System.out.println("윤년");
} else {
System.out.println("평년");
}
scan.close();
}
}
5. 윷놀이
- 4개의 윷 상태가 입력되면 도, 개, 걸, 윷, 모를 출력하는 프로그램을 작성하시오.
- 윷의 상태가 0이면 뒤집어 지지 않은 상태, 1이면 뒤집어진 상태를 의미한다.
윷놀이는 4개의 윷을 이용하는 게임이다.
도 : 1개가 뒤집어진 상태
개 : 2개가 뒤집어진 상태
걸 : 3개가 뒤집어진 상태
윷 : 4개가 뒤집어진 상태
모 : 하나도 뒤집어지지 않은 상태입력 예시
윷 상태를 입력하세요 : 0 1 1 1
출력 예시
걸
풀이
더보기
import java.util.Scanner;
public class Quiz04 {
public static void main(String[] args) {
Scanner scan = new Scanner(System.in);
System.out.print("윷 상태를 입력하세요 : ");
int num1 = scan.nextInt();
int num2 = scan.nextInt();
int num3 = scan.nextInt();
int num4 = scan.nextInt();
int sum = num1 + num2 + num3 + num4;
switch (sum) {
case 0:
System.out.println("모");
break;
case 1:
System.out.println("도");
break;
case 2:
System.out.println("개");
break;
case 3:
System.out.println("걸");
break;
case 4:
System.out.println("윷");
break;
}
scan.close();
}
}
반응형
'Algorithm > etc' 카테고리의 다른 글
[코딩연습] 메소드 생성 연습 2 (0) | 2021.11.03 |
---|---|
[코딩연습] 메소드 생성 연습 1 (0) | 2021.11.02 |
[코딩연습] switch 문 (0) | 2021.10.20 |
[코딩연습] if문과 논리연산자 (0) | 2021.10.20 |
[코딩연습] if문과 비교연산자 (0) | 2021.10.20 |